软件_手把手教vscode配置c++,python开发环境

之前主用Python作为项目开发语言,将项目迁移到arm边缘盒子上后发现arm的cpu不给力,软件速度低于预期,所以计划将部分程序改为c++实现。于是乎,复习了c和c++的一些知识,毕竟十多年未用了(上次用还是本科读书时)。未来一段时间可能将c++作为主力研发语言,之前上学那会使用的codeBlocks貌似也不怎么火了,最近风头正盛的时vscode,打算用vscode进行研发。
首先,vscode只能看做加强版的文本编辑器,不能看做IDE。为何?因为它的配置真的麻烦,对于我这种用过CodeBlocks,eclipse,IntelliJ IDEA,pycharm等IDE工具的人,真的认不下vscode的IDE身份。所以大家有个预期,配置有点小麻烦,照着步骤做就行。
以下操作都是在manjaro系统上完成,VSCode版本1.50.1。

docker_dockerfile和dockerCompose常用命令

Dockerfile是一个包含用于组合映像的命令的文本文档。可以使用在命令行中调用任何命令。 Docker通过读取Dockerfile中的指令自动生成映像。

软件_matplotlib绘图跳过时间段的处理方案

在绘制行情图时matplotlib,遇到时间索引会自动进行补全,导致dataframe不存在的记录实际绘图中也有,不过是一条连续平线。这个默认设计对大部分情况也是合理的,但在股票行情分析中,我们并不需要自动填充,反而需要跳过这些非交易时间段。
目前如果采用dataframe作为索引(index),网上也没有找到合适的解决方案

docker_docker安装jupyter采坑历程

背景:发现自己电脑配置不够,在进行模型参数调优时基本进行不下去了。计划使用云服务器,由于自己只是用来跑模型。所以按需计费最为合适。考虑到每次使用都需要部署开发环境,索性用docker实现。这样每次部署可以省去很多软件安装和部署工作。留下过程和采坑经历。供大家借鉴。
个人系统:ubuntu16.04

软件_pyspider抓取数字货币价格bitcoin

第一步,找数据源,发现数据源url的pattern

软件_pycharm报错pleaseSecifyADiffeentSdkName

这里有重复的名字 ,右侧的-号,把它移除掉就行了(本例子,都正常)

docker_docker安装TOPT

在docker中安装TPOT机器学习包。

软件_印象笔记无法同步EDAMSystemException

可能国内软件做的太人性化了,最近用的几个国外软件,真的各种反人性,尤其是今天的evernote,窝火!
1,网页web版,新版旧版并存,新版切换旧版,链接明显。旧版切新版,找不到入口!!请问,是在鼓励用户使用旧版么?那做新版干干嘛呢?用户一旦误点击,切换到旧版,发现,回不到新版了!!!!
2,同步问题,evernote在win上有客户端,可以正常同步,但是,我第一次用就无法同步,折腾了大半天,最后还是csdn搞定,
解决方案:工具——>选项——>同步——>勾选开启部分同步——>点击确认
猜测是某一篇文章,可能哪里有残缺,同步过程抛出异常,导致同步失败。
难道设计、开发人员都不动脑子?博文本身互相独立,即使某一篇报错,也不该影响其他文章吧!一篇文章报错,全部无法同步!!还有就是,既然有兼容性的配置项,难道不应该默认放开么??
evernote这种toC软件,理论上不应该出现这种低级问题,毕竟面向用户很广泛,而且大多小白用户,难道让人家去debug么?

软件_win10安装rqalpha

win10安装rqalpha
参考文档
rqalpha地址:https://rqalpha.readthedocs.io/zh_CN/latest/intro/detail_install.html#intro-detail-install
1,安装ubuntu和win10共存的双系统,失败,放弃
2,使用win10已安装的Anaconda2-5.3.0-Windows-x86_64.exe,参考官方文档继续安装
pip install -U pip
pip install -U setuptools

软件_避免用chrome进行网站配置调试

坑1:自动填充

Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×